Skip to main content

Software Assistant

Thomson Reuters Training & Support

FAQ

Read through a list of frequently asked questions from our customers and prospects.

Product questions

How to enter Australian Annuities and Superannuation Income Stream at Item 7

Error: CMN.ATO.GEN.XML01 - The message did not pass XML validation. Please contact your software provider.
The element 'AnnuitiesAndSuperannuation' in namespace...; or

Error: CMN.ATO.GEN.XML04 - A mandatory field has not been completed.
The element 'SISLumpSumArrearsPayment' in namespace...; or

Error: CMN.ATO.INCDTLS.000319 - Superannuation income stream lump sum in arrears amount details are incomplete.

Refer to the guide below if you see any of the validation errors above.

When claiming item 7 Australian Annuities and Superannuation Income Stream for tax offset amount as shown on PAYG payment summary, please complete ALL mandatory fields at item 7 worksheet. The mandatory fields are:

  • Pay Date (e.g. 30/06/2020)
  • 60Yr (refers to: Are you under 60 years of age and a death benefits dependant, where the deceased died at 60 years or over?)
    Y = The entity is in receipt of a reversionary superannuation income stream;
    N = The entity is not in receipt of a reversionary superannuation income stream
  • Tax deducted (enter $0, if nothing to claim)
  • Untaxed element (enter $0, if nothing to claim)
  • LSA-Untaxed element (enter $0, if nothing to claim)
  • Year (e.g. 2021)

For Australian annuity payments, the mandatory fields are:

  • Select type O - Australian Annuity payments
  • Tax deducted (enter $0, if nothing to claim)
  • Annuity gross

Please note, you won't be able to enter a description for type O - Australian Annuity payments.
 

How do I claim exempt foreign employment income

Complete the following fields in the item 20 worksheet:

  • Details of the foreign source income
  • Country
  • Exempt foreign employment income
  • Exempt foreign income tax paid
  • During the year did taxpayer own, or have an interest in, assets located outside Australia which had a total value of AUD$50,000 or more?

As per ATO's instructions and worksheet, exempt foreign employment income is not added to the assessable foreign source income (label E).
 

How do I enter foreign rent

Complete the following fields in the item 20 worksheet:

  • Details of the foreign source income
  • Assessable foreign source income label E - refer to the ATO's instructions and worksheet, CLICK HERE
  • Exempt foreign employment income (enter $0 if there is nothing to report).
  • Foreign rental income gross amounts (this amount needs to be the same as label E)
  • Other foreign income deductible expenses (enter the total rental deductions to be claimed)
  • Foreign rental income foreign tax paid
  • During the year did taxpayer own, or have an interest in, assets located outside Australia which had a total value of AUD$50,000 or more?
     
Validation - CMN.ATO.IITR.730355 - Foreign pension or annuity income details are incomplete

This error will appear if the Foreign pension or annuity income at item 20 is incomplete. Firstly, open the item 20 worksheet and check the Foreign pensions or annuities fields:

Foreign Pension error

If the taxpayer did not have any Foreign pensions or annuities then please remove any zeroes from the fields shown above. In the example above, deleting $0 from Foreign pension or annuity foreign tax paid will resolve the error.

If the taxpayer did receive a Foreign pension or annuity then refer to the "Claiming foreign pensions or annuities" knowledge article. 
 

How do I enter foreign pensions or annuities

To claim foreign pensions or annuities using the item 20 worksheet, you will need:

  • Details of the foreign source income.
  • Assessable foreign source income.
  • Exempt foreign employment income (enter $0 if there is nothing to report).
  • Foreign pensions or annuities gross amount.
  • Foreign pensions or annuities deductible expenses (enter $0 if nothing to report).
  • Foreign pensions or annuities undeductible purchase price (amount needs to be greater than $0; otherwise leave it blank).
  • During the year did taxpayer own, or have an interest in, assets located outside Australia which had a total value of AUD$50,000 or more?

If the gross or net amount is displayed at item 20L (Net foreign pension or annuity income WITHOUT an undetected purchase price) then you will need to manually enter $0 at item D11Y Deductible amount of undeducted purchase price of a foreign pension or annuity.

If you are claiming an amount at item 20D, the undeductible purchase price needs to be greater than $0. The undeductible purchase price amount will automatically transfer to item D11Y.
 

How do I enter foreign source income

The guide below will also resolve the validation error, CMN.ATO.GEN.XML04 - A mandatory field has not been completed.
The element 'ExemptForeignIncome' in namespace...

When claiming foreign source income and foreign assets or property at item 20, you must complete:

  • Details of the foreign source income.
  • Assessable foreign source income label E.
  • Exempt foreign employment income (enter $0 if there is nothing to report).
  • During the year did taxpayer own, or have an interest in, assets located outside Australia which had a total value of AUD$50,000 or more?
  • The relevant section for the foreign source income.

Please note, you need to create a separate worksheet for different sources of foreign source income.

If you need to report Employment income - non PAYG then,

  1. Leave Exempt foreign employment income blank.
  2. Enter Foreign income employer name.
  3. Enter Gross employment income under Employment income-non PAYG.
     
How do I claim lump sum E on 2020 and later individual tax returns

Firstly, check the ATO's prefill did not import data into the item 24 category 1 worksheet for lump sum payment. If it did, please delete the worksheet.

Complete the two lump sum fields in the income worksheet (item 1 worksheet).
•    Lump sum code
•    Lump sum amount - lum sum year and lump sum amount

Lump sum E1

The lump sum amount will automatically transfer to the newly added item 24 lump sum amount field. The software will also include $0 at item 24 category 1 to pass validation due to the new validation rules in the 2020 tax return.

Lump sum E2
 
 

How do I override item T2 Australian superannuation income stream?

On item 7 worksheet, leave the type blank to be able to manually enter the tax offset at item T2.

Additionally, you can create a new line on the item 7 worksheet and skip to the offset column to enter the amount.
 

Error: Registration error - 'You have used all licenses'

If you are receiving an error stating "All Licenses used" upon registering Software Assistant on various machines, it could mean that Software Assistant is registered on more computers than what was purchased.

If you have exceeded the license number you paid for, please call our sales staff who will be happy to discuss the discounted pricing structure of an extra license. 1800 074 333 (select sales) or contact your client manager directly.

If you have not exceeded the license number, please call or email support who will work through the issue with you.
 

Error: Installation error – 'Common 1722'

If you are installing or upgrading Software Assistant and encounter an error stating 'Common 1722' that is typically caused by anti virus software erroneously intervening during the install/upgrade process, resulting in a failure to correctly install.

We recommend you affirm Software Assistant as a trusted source within your anti virus software's "safe software listing" (located within your anti virus software). Please call your anti virus software supplier if help is required to complete this task, not Thomson Reuters support as we do not provide support for your anti virus software.

An alternative method would be to turn off your anti virus software whilst installing/upgrading. Remember to turn it back on, once the process is complete. This is not recommended as it may leave your practice vulnerable for a short period.

If you are still receiving the error after amending your anti virus software's "safe" listing, please contact Thomson Reuters support.

Error: I am unable to change the status of returns or forms

Make sure that the return has been saved first and that there are no validation errors present. Also make sure that your user account has access rights to sign returns.

How do I recover lost or forgotten client record passwords?

If you have lost or forgotten a client record password, please contact support for assistance.

How do I lodge the Work-Related Expenses Schedule?

To lodge the Work Related Expenses Schedule (D1 to D5), click on the ‘Other’ tab and then mark the 'Lodge Work-Related Expenses Schedule' checkbox.

Please note, the ATO has restricted the maximum character length of the schedule to 30 characters, starting from 2019 tax return.

How do I create a BAS/IAS form for other periods/ annual GST/ monthly period?

After a certain period, you will not be able to lodge BAS forms for a previous year using that year’s module (i.e. GA, GB, GI and GR forms). To lodge a previous year’s BAS form, create the form in a year that has PLS Activity Statement menu.

  1. Change the year period in the top right-hand corner of Assistant. Starting from 2014 and onwards will have the PLS Activity Statement.
  2. Select the client.
  3. Click on the down arrow next to the 'New' button and select 'PLS Activity Statement' and then the Activity Statement form required. 
  4. Enter the reporting period (located on the top right-hand corner of the form).
  5. Enter the ABN branch number, if required
  6. Go to 'Tools > Load values from PLS'. This will force the software to prefill the form for the reporting period.

Please note, the ATO has removed 1H from the electronic BAS form. They have advised tax agents will need to lodge the form on the tax agent portal to report for the GST instalments

How do I create a BAS form or an IAS form for a client?

You must have a client record present before you can create an Activity Statement or other forms for the client.

  1. Click on the down arrow next to the 'New' button.
  2. Select 'PLS Activity Statement'
  3. Select the desired form.
Error: 'Index is out of date' is shown when trying to open a return or ledger

If this occurs when you are trying to open Ledger:

  1. Close the Ledger.
  2. Select 'Tools > Repair ledger files'.
  3. Try to re-open the Ledger.

If this occurs when you are trying to open a tax form:

  1. Close Software Assistant.
  2. Open 'Verify and backup data' via the Windows Start Menu
  3. Tick only the first three boxes.
  4. Click 'Proceed'.
  5. Re-open Software Assistant.
Error: ‘The client with the same TFN has been detected’ is shown when signing returns for lodgment

There are two or more records created with the same client’s TFN. The records have to be merged or deleted.

To delete a redundant client record:

  1. Untick the 'Active' checkbox on left-hand-side navigator.
  2. Click on TFN column header to sort clients by TFN.
  3. Locate client by TFN and find below another client record with the same TFN.
  4. Delete the redundant client by selecting the client record and then selecting 'File | Delete client'.

To merge client records A and B:

  1. Export client A record to the file by right-clicking on the client’s record and selecting 'Export client to file (with docs)' menu.
  2. Delete client A's record by selecting 'File | Delete client'.
  3. Right-click on client B's record and select 'Change client code to…'
  4. Change client B's code to client A's code.
  5. Import client A from the export file by selecting 'File | Import data | Import exported clients'.
  6. Mark the records you wish to import (merge) in to client A (ex B).
Error: When trying to view help by pressing the ‘F1’ key, nothing is displayed.

You may be missing certain Software Assistant help files, or your keyboard is configured incorrectly.

  1. If you have a Microsoft keyboard, make sure the ‘F-Lock’ key is turned ‘OFF’. Try to re-open the help files.
  2. If you still cannot access the help files, navigate to 'C:\Program Files (x86)\Software Assistant\Assistant\Help'.
  3. Check to see whether you have help files for the year you are working on. These will be indicated by the return name followed by the year. E.g. ITR20XX, FTR20XX, Forms20XX.
  4. If you do not have these files, please re-install Software Assistant or download the full-install from our website.
How do I lodge an amendment for an Individual Return?

In order to lodge an Individual amendment form, you must have already lodged the original form and it must be in an ‘Accepted’ state.

  1. Open the original tax return.
  2. Make sure the status is marked as ‘Accepted’.
  3. Click on the arrow next to the ‘New’ button.
  4. Select ‘Tax forms’ and then ‘AR – Amend return or activity statement’ for 2011 and newer returns or ‘AI – Amendment of individual return’ for 2010 and earlier returns.
  5. Complete the amendment details, save and lodge the amendment return.
Error: What to do if you receive error $2501 upon opening Report Designer.

Please restart your machine and retry. If the problem persists, please contact support for assistance.

How do I use Bank Feeds?

Bank feeds are available at $22 per bank account annually with no ongoing fees or restrictions on number of downloaded transactions.

Order bank feeds on our order form. Bank feeds management will be added to your user portal, under the registrations section.

Use bank feeds management to register bank details. Net banking credentials will be required. Check with your client that the net banking account has an SMS code confirmation or any other security measure to prevent unauthorized transactions before registering the net banking details.

The bank feeds ID will be generated for each registered bank account and all available transactions will be downloaded to your user portal (usually three months of transactions). We use third-party services from Yodlee to retrieve the transactions.

The transactions will be refreshed automatically every night and stored in your user portal.

  1. Open ledger in Ledger Assistant and edit the appropriate bank account.
  2. Enter the bank feeds ID as generated in the user portal to associate the ledger account with the bank feeds connection.
  3. Select 'File > Import data > Import bank feeds' when ready to download bank transactions.
  4. Select the bank account from the accounts associated with the bank feeds and a period for which you wish to retrieve transactions.

Transactions will be imported to the transaction import screen where Rules can be used to automatically allocate the account numbers to the transactions based on keywords in the transaction description, date, reference and other criteria.

Training videos:

How to use Bank Feeds as a Tax Agent, click here.

How to use Bank Feeds as a client, click here.

How do I change the 'HP liability' account so that it appears under liabilities in the financial report?

Negative “Interest bearing liability” accounts (accounts 3200 – 3299) will be displayed as assets in the financial report. To force an account to stay in liability section:

  1. Select the account from the Accounts screen
  2. Click on the edit icon on the left
  3. Tick the 'Persistent category' checkbox.
How do I download Software Assistant’s complete installation or upgrades?
  1. Login to your user account from this link. If you have forgotten these details you can reset your password
  2. Click on ‘Update Centre’ from the left hand navigator
  3. You will be taken to the download page which will list all available downloads.
How do I download updates for Software Assistant?

There are numerous ways of downloading updates for Software Assistant.

  1. When a new update is released, we will send notification emails to all existing clients. The email will contain a download link to the update.
  2. When a new update is released, you will be automatically notified within Software Assistant via a popup message
  3. You can download updates directly from our website. Click here for latest updates
Error: 'Assistant’s registry items have been detected in virtual store'

Please contact support for assistance with this issue. 

How do I de-register Software Assistant?

Follow the steps below to de-register Software Assistant from your computer.

  1. Open Register Assistant (run a search for this application via your Windows Start Menu)
  2. Un-tick the modules that you wish to de-register.
  3. A message will appear asking if you would like to de-register the module, click 'Yes'.
  4. Click on the 'Register' button.
  5. The registration form will connect to our server and de-register the selected modules from your computer.

You can now register Software Assistant on another computer.

Error: 'Cannot find server' is shown when trying to register.

If no activation codes appear when you click try to register Assistant, check to make sure no firewall programs are blocking the registration form from accessing our server. This is common with CA, Norton, BitDefender, Trend and Avast Anti-virus. Either disable the firewall completely or add an exception to allow “register.exe” to access the internet. This file can be found in the following location:  C:\Program Files (x86)\Software Assistant\Assistant

If you receive a “Cannot find server” error message, check that your Internet connection is active and try again.

If you are still unable to register, you may be able to register the software manually.

Error: 'DATA directory is blank or does not contain 'Clients.DB'' is shown when trying to Configure BDE

This error occurs when there is no Clients.DB file in the folder you are trying to link Assistant with. Verify that your data directory is correct. You must have a Clients.DB file in your data directory. If not, you are either pointing to the wrong directory, or you may have a corrupt DB file.

Error: 'Network initialization failed: Path not found' is shown when trying to open or upgrade Software Assistant.

You may need to 'Configure BDE' if your database is on a server or network drive.

  1. Open Register Assistant via the Windows Start Menu (run a search for the application)
  2. Click on Advanced
  3. Ensure the Data directory path is correct
  4. Click on Configure BDE
  5. Close the form
  6. Re-run the update or upgrade.
Error: 'Assistant has NOT been registered’ is shown when trying to open Software Assistant.

You will most likely come across this after installing onto a new computer or after an update.

  1. Open Register Assistant via the Windows Start Menu (run a search for this application)
  2. Ensure the software is showing as registered. Complete the registration process otherwise.
Error: 'The directory is being controlled by another .net user' is shown when trying to open Assistant.

This problem can be caused by the computers on the network having a different database path to one another.

  1. Make sure everyone on the network has logged out of Software Assistant.
  2. Go to Assistant’s Data folder, usually 'C:\ProgramData\Software Assistant\Assistant\Data', unless your data is on a network drive.
  3. Locate the following files 'PDOXUSRS.NET' and 'PROXUSRS.LCK' and delete these files if present.
  4. Open Register Assistant via the Windows Start Menu (search for this application)
  5. Click on Advanced
  6. Check that the data directory is correct in the registration form then click on the 'Configure BDE' button.
  7. Repeat the above step on all computers. Make sure all computers have the same data path (the drive letter can be different but the rest of the path to Software Assistant’s data has to be identical on all computers).
  8. Open Verify and backup data via the Windows Start Menu (search for this application). 
  9. Tick the first three boxes only and click on ‘Proceed.’
  10. Attempt to run Software Assistant on all computers.
How do I get returns to show in the lodgment queue after setting the return status to ‘signed’.

If you have set the return status to signed and it is still not showing up when you click on the PLS button, then the agent reference number in the Options form does not match the agent number in the tax return, or it is missing. Software Assistant will only include tax returns in the lodgment process if their agent reference number matches the one entered in the User section of Software Assistant’s Options.

  1. Open Software Assistant’s Options
  2. Click on the User tab
  3. Make sure the agent reference number matches the one in the return.
How do I enter previous years transaction entries in the Ledger?

To create entries for a past financial year in the present year, you’ll need to configure that client’s ledger for a previous year.

  1. Open the Client Details form.
  2. Click on the Ledger tab.
  3. In the 'Year ends' field, enter a previous financial year.
  4. Click on the Ledger button. A general ledger will be created for the client with the current period being the year you specified.
  5. To create transactions for a later year, you have to double click on the 'Close Year' command.
How do I restore from a backup file?

To fully utilise Software Assistant’s restore facility, you should set the backup feature to backup the database every day. This way you will have a wide range of backups to choose from. Assistant backup files are located in the _Backup folder in Assistant’s Data folder.

To restore from a backup:

  1. Select 'File > Restore from backup…' to open the Restore data form.
  2. The Restore Data form will list all the backup files available to restore from, sorted from earliest to latest. Select the backup file from the list and click Next.
  3. The Restore Data form will now show contents of the backup file. From here you can choose to earlier restore all data for a particular client or restore only the selected documents.
  4. To restore all data for a client: select the client from the list, mark the 'Restore all client data' option and then click on Restore. Repeat this if you wish to restore data for another client.
  5. To restore only the selected document: select the client from the list, then in the Client’s folder window, select the document that you wish to restore, mark the 'Restore selected document' option and then click on Restore. Repeat this if you wish to restore another document.
  6. Click on the Close button to exit the Restore Data form.

Please note that the restore function can only restore one client at a time.

Error: When printing reports, the date format is incorrect.
  1. Open the Windows Control Panel.
  2. Select Region and Language (or Regional language and settings).
  3. Under 'Format' change to any other language and click Apply
  4. Change the 'Format' back to your preferred format and click OK
  5. Re-open Tax Assistant
Error: 'Cannot load driver' is shown when opening the Assistant Diary.

This error is related to your printer drivers. This usually occurs when your printer is using a “Universal Print Driver” rather than the individual driver for your printer. Please download the individual printer driver for your printer from the manufacturer's website rather than using a Universal Print Driver.

How do I deactivate or activate a client?

To deactivate a client:

  1. Select the client from the client list.
  2. Select 'File > Deactivate client'. The deactivated client will not be shown in the client list unless the 'Active' filter is disabled.

To activate an inactive client:

  1. Remove the tick from the 'Active' filter on the left-hand navigation bar.
  2. Find the inactive client from the list. Inactive clients are indicated by their pale colour.
  3. Select 'File > Activate client'. This command will only be available when an inactive client is selected.
How do I reset the Software Assistant layout?
  1. Click on the 'View' tab in Assistant.
  2. Select 'Default layout'.
How do I transfer the Software Assistant database between computers?

There are a few ways of doing this. The easiest way would be to copy and paste the entire data folder from the current computer to the same location on the new computer. Alternatively, you can also mark and export the clients and then import them into the new computer.

Method 1: To copy the data folder (recommended method):

  1. Locate the data folder on the current computer. The default path is 'C:\ProgramData\Software Assistant\Assistant\Data'. You can check your location via Options > Directories in Assistant. 
  2. Connect a USB flash drive.
  3. Right click on the data folder and select 'Copy'.
  4. Navigate to the flash drive, right click and select 'Paste'.
  5. Insert the flash drive into the new computer.
  6. Copy the data folder from the USB flash drive to Assistant’s existing data folder on the new computer. Click 'Yes' when asked to overwrite the existing files.

Method 2: To transfer the clients using export/import:

  1. Right click on the client list and select 'Mark/Unmark clients …' .
  2. Click on mark 'All clients' and click 'Execute'.
  3. Select 'File > Export data > Marked clients'.
  4. Save the zip file to a USB flash drive.
  5. Connect the flash drive to the new computer.
  6. In Assistant, select 'File > Import data > Import exported clients'.
  7. Locate the zip file that you saved onto the USB drive, and click 'Open'.
  8. The clients will be automatically transferred into the client list.
When trying to print a report, you receive the '1722 RPC server unavailable' error.

This error is caused by your Firewall blocking access from Software Assistant to print. You must allow Assistant.exe permission through your Firewall or add this executable to your firewalls trusted list. If the files displayed are missing from Software Assistant’s Data folder. Restore the missing files.

'Invalid date format' is shown when opening a return or worksheet.

To rectify this issue:

  1. Close Assistant
  2. Open the Windows Control Panel.
  3. Select Region and Language (or regional language and settings).
  4. Under 'Format' change to any other language.
  5. Press Apply
  6. Change language back to 'English (Australia)'
  7. Open Assistant
  8. Re-open the tax form.
How do I insert my company logo in various letter templates?

To insert your company logo into a letter template or any image to the letters or notes template:

  1. Locate the image file.
  2. Right-click on the file and select Edit.
  3. Select the whole image (shortcut key is CTRL + A).
  4. Select 'Edit | Copy' (shortcut key is CTRL + C).
  5. On the software, go to File > maintain templates and select either Letters Templates or Notes to Accounts.
  6. Open the Assistant Letter Editor located on your taskbar.
  7. Select the desired template.
  8. Left-click in the place where you wish to insert the image. There needs to be a blank line on the very top of the page so insert the image in the line below if you want the image to be on the top of the page.
  9. Press 'Shift + Insert' or 'CTRL+V' to paste the image.
  10. Click on the Save button.
Where can I find the Software Assistant End User Licence Agreement?

The Software Assistant End User Licence Agreement can be found here.

How do I uninstall Software Assistant?
  1. Open the Windows Control Panel
  2. Then click on Programs and Features
  3. Locate the application named 'Assistant'
  4. Then click on Uninstall

*Warning* Removing the Assistant application before taking a backup of your files may result in data loss. 

Does Software Assistant have Single Touch Payroll (STP) reporting capabilities?

We are not implementing STP reporting (Single Touch Payroll) in Software Assistant at this stage. 

Validation - CMN.ATO.GEN.001001 Mandatory field not supplied - Report TypeVariation Code

When the PLS Activity Statement form is created, the software will prefill from the ATO's server to get the document ID and type variation code. Refer to the ATO website for the list of type variations.

Type variation code field
 

If the PLS Activity Statements form does not prefill and you get the message, "no activity statement available" then the taxpayer has an ABN branch number, which you need to enter in the client details (next to the ABN) then create the form again.

ABN branch number field

The taxpayer's ABN branch is shown on the tax agent portal > activity statement page. Next to the Activity Statement text, you may see 00#.

What happens when the subscription ends?

When the Tax Assistant subscription ends, the system will automatically switch to read-only access for all the tax returns.

Additionally, if you don't plan to renew the Ledger Assistant subscription, please let the support team know at the end of the expiry date so we can enable read-only access for it as well; otherwise, it will be locked if no other licenses are renewed.

ERROR_ITEM_VALUE_INVALID_PATTERN : "XXXX" does not match the pattern "[0-9]{2}"

The telephone area code on the cover page and/or declaration page of the tax return can only be two digits long. You will need to delete and retype the telephone area code so the fields are correctly updated.

Validation - CMN.ATO.AS.EM060 - X was reported as XXXX and will be corrected to XXXX

Most likely the ATO records do not have the reported amounts so their system expects the item should be another amount. You will need to contact the ATO to get them to update their records for any variations before lodging the BAS/IAS form again.

How do I set up beneficiary/member accounts?
  1. Open Client Details panel
  2. Go to the Ledger tab
  3. Enter the number of beneficiaries/members
  4. Go to the Other tab
  5. Enter a number (starting from 1, not 01) and name (optional - percentage of income to be split)
  6. Open the ledger
  7. Click on Postings tab
  8. Then select Transaction Journal Wizard > Setup Rental or Member Accounts
  9. Select the member from the drop down list and then click on OK

Repeat the steps based on the number of beneficiaries/members listed for the entity.

If you have more than 9 beneficiaries/members then make sure to increase the account length to 5 or 6 by going to client details > ledger tab.

If you cannot see the member's name on the member's statement in the financial report then you need to follow the instructions above. Re-open the ledger if the software does not refresh.

How do I manually post to GST account?

Use account 3529 GST payments/refunds if you need to make manual adjustments; otherwise, "G18 - Adjustments" will not calculate correctly in the GST report.

Do not use accounts 3510 and 3520 as these are automatic accounts.

How do I allocate profits to beneficiaries/members?

Check you have setup beneficiaries/members accounts correctly. Refer to "How do I set up beneficiary/member accounts"

  1. Go to the Postings tab.
  2. Click on Transaction Journal Wizard .
  3. Click on Profit Distribution/Member Accounts Allocation.
  4. Enter the % share or $ amount.
  5. Click on Transfer to post the transactions for the profit distribution to the beneficiaries/members.
Error calling SBR Core Services/ Send Request Failed error

Most likely the ATO's PLS server is experiencing technical issues or under maintenance. To view the ATO's PLS status, CLICK HERE.

If the status is operational then contact the support team to troubleshoot the issue further.

How do I lodge an early tax return?

The early year of the tax return is not available. You can use the software to enter the data and print the tax return to mail it to the ATO. Make sure to cross out the year and mark the correct year on the tax return. Refer to the ATO website for more information.

Post your completed tax return to:
Australian Taxation Office
GPO Box 9845
[insert the name and postcode of your capital city]

Error reading PrintDialog1.Copies: Operation not supported on selected printer

You will need to re-select the default print from Windows Control Panel.

Validation - V2885 - Subtotal 2 must equal subtotal less Non-refundable carry forward tax offsets

Restart the software to resolve the validation error.

ERROR_ITEM_VALUE_MAX_LENGTH_INVALID : Invalid length XX, where maximum length expected was 30

Due to the implementation of the Granular Data Reporting, the ATO has restricted the description length to a maximum of 30 characters (includes spacing) per line. Therefore check the description that the validation error has identified is no longer than 30 characters. If all the descriptions are fine then refer to the steps below.

The work related expenses schedule description is rolling forward from a prior-year tax return. If it is no longer needed then you should delete it or shorten the text to a maximum of 30 characters as per ATO requirements.

  1. Go to the Other tab
  2. Tick the work related expenses schedule box
  3. Go to the item worksheet the validation error is referring to
  4. Remove the text in the top box or shorten it to only 30 characters
  5. Click on the save button on the worksheet
  6. Go back to the Other tab and remove the work related expenses schedule tick box.
Random characters appearing on letters/ financial notes templates

The random characters will appear when you use MS word to edit the RTF templates. You should open the file with notepad or wordpad; otherwise go to File > Maintain templates > Notes to financial report and open the relevant template and click on the save button to re-save the file, which will remove the random characters.

Validation - CMN.ATO.GEN.500054 - Intermediary declarer Australian Business Number has failed the algorithm check

Enter the tax agent's ABN in Options as the intermediary declarer refers to the tax agent.

Validation - CMN.ATO.IITR.200001 / CMN.ATO.IITR.200002 - Questions relating to the full individual return form must be answered

Items 18G, 19I, 19W and 20P are required to be answered (Y/N) to pass the validation error.

Please note, if item 19K and B is $0, you need will need to delete the $0 as it is not required.

If item 20P is blank and there is no worksheet for item 20 then,

  1. Open item 20 worksheet
  2. Enter something in the "Details of the foreign source income" field
  3. Click in the box to answer Y/N for label P
  4. Click on Exit
  5. Open the item 20 worksheet again
  6. Click on Delete and Exit
Validation - CMN.ATO.IITR.310066 - Capital Gains Tax schedule required

When the net capital gain is in excess of $10,000 a Capital Gains Tax schedule must be attached. 

The capital gains tax schedule and all other schedules are located on the navigator panel as shown.

Validation - CMN.ATO.IITR.210016 / CMN.ATO.IITR.211016 - Spouse Details Required

Make sure you have completed item IT8 Number of Dependent Children in the Income Tests section.

How do I post for closing inventory / livestock?

Make sure to transfer the inventory account or livestock account from the master chart of accounts before posting to them then follow the instructions below.

  1. Go to Postings tab
  2. Click on Transaction Journal Wizard 
  3. Select Closing Stock Adjustment
  4. Enter the inventory/ livestock details
  5. Click on the Transfer button to post the transactions
How do I create rental property accounts?
  1. Go to Postings tab

  2. Click on Transaction Journal Wizard  

  3. Select Setup Rental or Member Accounts

  4. Enter the name of the property (maximum character length with spaces is 42)

  5. Click on OK

If you have another rental property then repeat the steps and increase the Property ID number.

If you have more than 9 rental properties then you will need to increase the account length to 5 by going to client details > ledger tab.
 

How do I lodge Taxable payments annual report?

Taxable payments annual report is not available on Software Assistant.

As per ATO's instructions, you can lodge online through:

  • ATO online services for individuals and sole traders – select ‘Tax’ then ‘Lodgments’ then ‘Taxable payments annual report’.
  • the ATO Business Portal – select ‘Online forms’ from the menu then ‘Taxable
Lodgement - Communication Exception occurred connecting to Vanguard STS

Generally, this error indicates that the Windows date/time is set incorrectly. Check to ensure your date and time are set correctly via the Windows system clock at the bottom right corner of your screen. Refer to Microsoft's instructions to change the time on your computer, CLICK HERE.

Additionally, this error can appear if a Firewall is active and is blocking the connection between yourself and the ATO. Try disabling your Anti-virus or Firewall and attempt to re-lodge.

If all else fails then there is an issue with your machine credential. You should delete the machine credential and get a new one from the ATO's relationship manager. Refer to the "How to setup machine credential" topic.
The default location of the machine credential is C:\Users\[USER]\AppData\Roaming\ATOMAS.

How to change the form's name shown in the client's folder

1.    Open the form
2.    Click on the Status button
3.    Enter the new name in the Caption field
4.    Click on OK
5.    Press F5 to refresh

How to mark tax return as Final?

Click in the box then either double click on the mouse or press the space bar on the keyboard to mark the tax return as Final.

Update error - MS17EBF.tmp being detected by antivirus

If the MS17EBF.tmp is being detected by the antivirus software then you will need to add it to the exceptions list or pause the antivirus before running the update.

Is Software Assistant compatible with cloud-based sync software such as Dropbox, Google Drive, One Drive?

We do not recommend the use of cloud syncing software such as Drop Box, Google Drive, OneDrive etc due to the nature of the Software Assistant database.

Software Assistant's database engine will lock files when they are in use and may cause errors and data corruption as the cloud software tries to sync these files.

If the user still decides to use these cloud based software then we cannot be held responsible for any data loss and cannot assist in any data restoration.

Tax Audit Alert not working

For the Tax Audit Alert to trigger,

  1. Enter the taxpayer's gender in the sex field of the client's details panel
  2. Select the occupation at item 1
  3. Record the deduction at the deduction items

The Alerts button will only light up when the claimed deduction amount is above the ATO's average amount.

Validation - CMN.ATO.TRT.432637 - Each Statement of Distribution must contain distribution amounts

A Statement of distribution must include an amount against at least one of these to clear error: 

  • Primary production income
  • Non-primary production income
  • Franked distributions
  • Franking credit
  • TFN amounts withheld
  • Australian franking credit from an NZ company
  • TB Statement-Tax preferred amounts or 
  • TB Statement-Untaxed part of share of net income.
How to setup lodgment and prefill

To connect Software Assistant to the ATO's practitioner lodgment service (PLS) and enable prefill and lodgement, you will need to first setup the machine credential. Please note, the software ID is not required due to the fact Software Assistant is not a cloud software.

Refer to the ATO's instructions on how to download the machine credential from the link below.
https://info.authorisationmanager.gov.au/guide-how-to-install-a-machine-credential

If you need help to download the machine credential you should contact the ATO's support line on 1300 287 539 (select option 3 for RAM enquiries) between:

  • 8.00am and 8.00pm, Monday to Friday
  • 10.00am and 4.00pm (AEST), Saturday and Sunday.

To enable the ATO's extension (ATOBE) on Chrome:

  1. On your computer, open Chrome.
  2. At the top right, click More More and then More tools and then Extensions.
  3. On the ATO's extension, click on the Toggle icon.

To enable the ATO's extension (ATOBE) on Firefox:

  1. Open Firefox.
  2. Click/tap on the Menu button, and click on Add-ons.
  3. Click on Extensions.
  4. On the ATO's extension, click on Enable.

Make sure to reset the internet browser before going to the RAM website. To access the RAM website, click on the link below.
https://authorisationmanager.gov.au/#/login

Once you have downloaded your M2M credential, please follow these steps to enable authentication via M2M on Software Assistant.

  1. Navigate to the Software Assistant Options.
  2. Click on the ATO tab.
  3. For the M2M location, leave it as default if you have saved the M2M credential file in the default location given by the ATO. Otherwise, choose the custom option and select the location where you have saved your machine to machine credential.
  4. Enter your M2M password.
  5. Click ‘Ok’.
Validation/Lodgment - ERROR_TAXONOMY_LOAD

You may encounter the error 'ERROR_TAXONOMY_LOAD' when validating or trying to lodge a return.

For example: ERROR_TAXONOMY_LOAD: An error occurred while loading taxonomy "file://C:/Program Files (x86)/Software Assistant/Assistant/SBR2/Taxonomy/schema/ ..."

 

This error is due to McAfee Total Protection security software flagging a false positive. 

Click on the guide below for instructions to resolve this error:
Validation/Lodgment - ERROR_TAXONOMY_LOAD

How to troubleshoot CMN.ATO.GEN.XMLXX validation error

How to troubleshoot CMN.ATO.GEN.XMLXX validation error

CMN.ATO.GEN.XML01 and/or CMN.ATO.GEN.XML04 validation errors will appear in your validation form with the error CMN.ATO.IITR.730488 and this means there are issues with the data recorded in the income items on the tax return.

Try to resolve the validation errors by following the steps below.

  1. Highlight the CMN.ATO.GEN.XML04 or CMN.ATO.GEN.XML03 and open the validation report (see circled icon).

     
  2. In the validation report, you will see “The element ‘……’ in namespace”. This will list the worksheet associated with the error. In this case, it is the Gross Interest worksheet in which the data has imported from the prefill.
    A picture containing text, screenshot, font, line</p>
<p>Description automatically generated
     
  3. “List of possible elements expected” will mention what field in the worksheet is missing. If the worksheet is not necessary and there is no amount then delete it. If the worksheet is necessary, please fill in the expected fields in the worksheet.

Most worksheets cannot have a blank value in them so if there are any records with just the description, please delete the entire row and try to validate again.

How to register the software

After installation or update you will need to register the software otherwise you will not be able to use the software.

Please note that the registration details are the same details used to login to the Software Assistant website portal and not the password used to log into the program.

To register the software, click on the 'Go to registration form' link on the login screen or click on the Windows Start Menu and search for 'Register Assistant'.

  1. Then on the Registration Form, make sure 'Registration user' checkbox is unticked
  2. Enter your registered email address in the username field. Password field should be greyed out
  3. Tick the modules that you have subscribed for
  4. Then click Register
  5. A new sign in window will appear with your email address already entered. Enter your password and click Login
  6. You will then be returned to the registration form and the message 'User logged in successfully' will appear. Click OK
  7. You will then see the message 'Registration completed'. Click OK and the registration form will automatically close
  8. You have now successfully registered the software. 

 

How to reset Software Assistant account password

Follow the steps below if you have forgotten your password.

  1. If you have forgotten your password, click on the link below to reset it
    https://www.softassist.com.au/Clients.aspx
  2. Enter your email address and then click 'Sign In'
  3. Then click 'Reset Your Password'
  4. Confirm your email address and then click 'Send Link'
  5. A Reset Password email will then be sent to your email address. Follow the instructions in the email to complete the reset.

Please note that this password is for your account login and registration.

For more information on our sign in process, please click here.

What are the system requirements for Software Assistant?

Recommended hardware and software for Software Assistant

The following are recommendations for running Software Assistant and related software. Actual requirements will vary depending on the size and daily operations of your practice.

Workstation

  • 1-gigahertz (GHz) 32-bit (x86) processor or 1-GHz 64-bit (x64) processor 
  • Windows 10 or later 32 or 64 bit operating systems 
  • 8 GB of system memory 
  • 1 GB of free hard disk space (program files and blank database, plus 1 MB per client) 
  • Windows-compatible pointing device 
  • 16 bit True Colour display adapter 
  • Monitor capable of 800 x 600 or higher screen resolution 
  • Internet connection

Server

Software Assistant does not require a server to operate. However, when working in network environment, a dedicated server with sufficient RAM, Storage and CPU to support the users and applications you are running is advisable.

Dedicated server with sufficient RAM, Storage and CPU to support the users and applications you are running.

Server Operating System: Windows Server 2008-2012, Small Business Server 2008-2012

Other equipment

  • Printers: A laser printing system is recommended for printing with Software Assistant. When printing remotely via terminal server, remote desktop or Citrix, please ensure you have the correct printer drivers installed.
  • Scanners: When using a locally connected scanner, ensure that the driver is TWAIN compliant. In order to scan in a remote session environment (terminal server, remote desktop or Citrix), you must utilise the network software provided with your scanner hardware or other third party applications.
  • Linux: Software Assistant is not currently compatible in a Linux environment.
  • MAC: Software Assistant does not support direct installation on a MAC; however, it is possible to configure Software Assistant on a MAC in a Windows virtual machine. Software Assistant is compatible across tested VM software, VMware Fusion and Parallels (others should work, also). When using a virtual machine, it may be necessary to select ‘bridged’ networking mode in order to lodge successfully. Please consult your software advisor for your Virtual PC software for instructions on how to do this.